[Solved]Share Drives on Network

I just received my Zima Cube and i am unable to access any of the drives as network shares. When I try to connect I get a message saying there are no shares available. I can’t find any settings in the OS to enable/modify etc.

Can someone point me in the right direction?

1 Like

I came here to post the same issue:

Just received ZimaCube and cannot access it inside Finder on Mac.

It does show up (sometimes with an Apple Airport icon, sometimes with a screen icon) but I simply cannot login/authenticate.

When I tested my first RAID it did allow me to access a folder I created through Dashboard/Files, but only as a guest. Now after creating a new RAID, it still shows the old folder I had created, but obviously it doesn’t work / go anywhere.

I have the Zima client app installed. At first when I clicked “Open in Finder,” it just opened the Dashboard in Safari.

Now it’ll open Finder and try to connect to SMB, but when I try to login in, it simply doesn’t work. I can see the login option direct from the Finder network section and via SMB with the IP address, but it does not work.

Ironically, with my first RAID, I think I got it to login on iOS in the Files app. It’s still in the Files app, but now it’s showing that old folder from the old RAID and isn’t update to the current files.

Not sure what’s going on but I really need direct Finder integration. (Especially since the Zima Files app doesn’t even load sizes of folders or allow multiple copies.) I can’t transfer my 20TB of data until Finder’s working!

Cube shows up in Finder, as an Airport.
Screenshot 2024-06-14 at 12.58.44

Login window shows up, but when I enter correct password, it just shakes / gives an error.
Screenshot 2024-06-14 at 12.59.33

And SMB used to load and show the login panel, but now it actually gives an error. — I just tried it again and the login panel showed up, but it shakes again / gives an error.
Screenshot 2024-06-14 at 13.00.21

(Random: the Backup Folder option worked and saved a folder to the Cube’s internal storage.)

I have tried using both Mac and Windows. When I click open in finder or open in explorer it opens in the default browser.

When I try navigating to the ip through Finder or File Explorer it can’t find any resources.

Apologies for this, SMB is currently only accessible via guest, and the current permission flaws will be patched in a future release.

1 Like

@NOLAHItch @Ns2Kracy @Ns2Kracy

  1. Once at least one folder has been shared by Samba, Zima Client’s “Open in Finder” will become effective

  2. When connecting Samba on Mac he WIndows, use the Guest account

After the above operation, if there are other failures please let me know.

1 Like

Thank you for the reply!

This appears to work — as a workaround at least. For now I’ll have to create folders in Zima Files. I created a few new folders in Files. It appears the sharing must be ‘initiated’ on each folder individually; the new folders didn’t show up in Finder without sharing the new ones. Each folder is basically mounting as if it’s own drive.

@Ns2Kracy Do I understand correctly that this is the exact issue you’re working on? Once we can authenticate with our username, we’ll be able to mount the Cube like a normal drive?

Yeah, just like you did before.

You can share a batch of folders by sharing the “upper folder”. Do you want all the folders you can see in the FIles app to appear on your computer? We are moving in this direction. @timothy

1 Like

@ETWang1991 Is there a way to clear the shares list on the ZimaCube? That is, clear the list so it shows only the currently active shares?

What I am seeing is that previously shared folders that no longer exist are still populating the available shares list when using the Zima Client’s Show in Finder option.

See the attached screen shot. Nearly all of the entries on that list no longer exist.

Screenshot 2024-06-19 at 9.14.30 AM

1 Like

I could be wrong but isn’t that like to be caching of the old share name on the Mac?

That certainly how it works in Windows land, the folder names are stored in the pcs registry for user convenience…

I’ve not seen that an issue in other use cases, but worth a look see! I’ll go clear all the caches and see if that does the trick.

No love. Clearing caches didn’t help.

Also - I tested a guest SMB connection to my cube using a Mac that was naive with respect to connecting to the cube and the full list as noted above came up as possible shares even though all but one on that list no longer exists. That makes me think the list is cached on the cube and is not being updated as to the shares that are actually available.


Maybe, as I said Windows caches a lot of data in the registry in the Most Recent Used keys, and very few users know enough to clear them out. Even some of the “registry cleaners” don’t fully remove them so I would not be supprised if the same process happens somewhere on a Mac, I’ve just no idea where it may be on a Mac