[Solved]USB Functionality Question

How do the USB ports work on the Cube?

When I got my Cube a week ago I tried connecting one of my external HDDs via USB A, but that just prompted ZimaOS to want to erase and format the drive. So I can’t even mount external HDDs into Files?

When I tried connecting a two different drives yesterday, via USB A on front and back, and via USB C on front, I didn’t notice anything occur in the Cube this time. No “new drive to format” and no new storage in Files. Has USB also been disabled recently? (Oddly, the LED on the drives didn’t even stay lit, as if they weren’t being powered. The light would flash then turn off.)

This question is semi-related to my question about connecting directly to a computer. But even aside from that, some clarity on “what the Cube does with USB drives” would be helpful.

Can you tell me what the file system format of your usb drive is? Usually the usb hard disk will be mounted directly, while it can be viewed in files.

@timothy If you’re plugging in a common format hard drive, you’ll see it at the bottom left of Files and can manage your files
image
image
In the next system version (v1.2.2), there will be an active prompt after the USB is inserted. If the disk format you insert is not common, it may not be recognized. Please let us know to help us improve compatibility @timothy

Thanks @Jerry and @ETWang1991

Where the arrow points is exactly where I expected to find them, but they’re not there.

I believe all of my disks are in APFS. I don’t use anything strange.

On v1.2.0 I remember the disk showing up in the format section, but at that time did not check Files since I was new to ZimaOS and didn’t think to check. But now, neither HDD nor SSD show up, not even in the storage/RAID format section. So I wondered if something changed with v1.2.1?

I’m very sorry for the bad experience, and the first thing that needs to be made clear to you is that there is no loss of your data. You may need a few steps to do a check, 1. check Storage in settings to see if there is a new hard drive and storage space, take a screenshot at your next reply if convenient. 2. you can re-plug the usb to see if there is any change. 3. you can try to reboot to see if the display is normal. Thanks for your feedback.

Translated with DeepL Translate: The world's most accurate translator (free version)

We took a closer look at ZimaOS and found that the current NTFS and FAT32 USB drives support read and write, but APFS does not support it, the IW team has documented this problem and is looking for a quick way to support it. @timothy

1 Like

I’m not concerned about data loss in this case. When I reconnect them to the computer they show up normal.

@ETWang1991 Thank you for addressing APFS support.

Hi Timothy,

Have you thought about adding a 2.5g Thunderbolt NIC to your mac and using a cat6 cross over cable? You would just need to assign a static IP to the Thunderbolt NIC on your mac and one to the zimacube interface. This should allow you to get some really good speed to do a bulk data transfer.

1 Like

I had not thought of that, thank you! A bit easier than installing PCIe.

Might you or someone else be able to help me figure this out?

The NIC is connected to the Cube via Cat6 crossover.

Screenshot 2024-07-18 at 10.42.05

The Cube already found this and gave it an IP, x.178. (I do not see any way to change a static IP. I did make the separate IP for the router a reserved IP.)

Screenshot 2024-07-18 at 10.17.03

This is what Settings is seeing, what do I need to change here? When I SMB to x.178 it wants my Mac’s login and then mounts my own attached harddrives as SMB drives. It’s not accessing the Cube.

Is SMB even the right protocol when using the NIC?

Screenshot 2024-07-18 at 10.12.57

Like someone else just posted about selling their Cube since it can’t connect to Finder, I’m also quite disappointed this was limited to the “Pro” version. It seems like a basic feature and was not something I foresaw being such an issue. Ive never had a NAS before and didn’t know what to look for. With SMB I’ve had some large transfers fail in one way or another or just be so slow, so I’m not sure how I’m supposed to copy 25TB when APFS drives (and also Mac OS Extended drives) still can’t even be connected to the USB ports! (Thus I’m hoping the direct NIC connection speeds things up a bit.)

@ETWang1991 Is there any way to reconfigure the front USB C connection to be able to connect the Cube directly to a computer, like the back USB/TB connection on the Pro?