Unable to open case

I just received my Zimacube on Monday. I wanted to take a look at the motherboard, available slots, ect., before setting it all up. This is where the problem comes in. The hex screws and the included hex screw driver.

The screw driver is able to remove the bottom case screws, however it can get a grip on the top 4 screws. Those screws just start to instantly strip out.

I’m getting same. Included hex key just seems to spin… tried imperial and metric size keys and none of them fit… What size is it supposed to be?


Hi both, I’m having the same issue too, at least 2 of the hexagon screws are stripped and I can’t open the case too… really disappointed.


Ok… So the screws are star or Torx T9 size… I got it opened finally…


We apologize for the inconvenience. Seeing that John shared his method, maybe you can try it first. If it still doesn’t work, we will deliver additional equipment.We will update this detail in the upcoming docs.

Thank you!

It does seem that although the visible part of the screw makes it look like it’s hex, deeper in it is Torx T9

John1’s use of T9 Torx bit does work… The surface half of the head though appears to be Hex and it’s only deeper in which you can see the star pattern of the Torx bit.

Is there documentation on the actual screw size? Honestly I think i’d like to replace them with a another screw type like a phillips-head to make finding tools easier later on.

I dont know if the supplied tool is supposed to be a star… It says it is and kinda tries to grab but no go. You can see side by side with Torx T9… Nothing like it…


6-32 British head, length: L:8mm

1 Like

Is it 1.2mm or cm?

@777-Spider given that the provided screws are faulty, will Icewhale be sending replacement screws?

Sorry,I edit the size.If you would like to have the screw replaced you can contact support@icewhale.org