Cannot connect to ZimaBlade [RAM INSTALLED]

Hi all,

Today I tried setting up two Zimablades. They are both unreachable.
With 1 of them I can see the IP address:

But the page doesn’t load:
“The server at is taking too long to respond.”

I have these memory modules: G.Skill DDR3L F3-1866C11S-8GRSL

1 Like

Anyone got tips or tricks, otherwise I will send them back.

Does the device light up red (next to the USB-C connector) but nothing else happens?
I got the same problem

Yes it lights up. The modem port lights up too but I don’t see it in my modem anymore. Going to try and get a mini display cable and see whats up.

Did the same with ab USB-C display but the device did not seem to do any output

What a shame this issue occurs on both of these units. I feel Icewhale is dropping the ball. I email support so I might get help within 2 weeks if i’m lucky.

Having same issue after trying to set mine up last night. USB C 45 watt power brick, tried going direct into monitor with minidisplay to hdmi, 16 gb icewhale ram installed, keyboard in, Ethernet into local switch, and nothing displayed on monitor nor could I find it on network, I wonder if this is a wide spread issue :\ such a shame, I was really looking forward to this unit for a couple months

This is not an isolated issue anymore. Too many people with this issue…

Spr, I see an article stating to replace the RTC battery via the back plane. I’m going to try it and I’ll let you know if anything changes

Did you get help? If not,I can help you!

I have the same problem. I need help. I installed the ram, but it won’t be recognized in the windows client.

Do I have to install CasaOS before somehow? and if so how?

No, I tried alot already. Please share how you can help.

I’ve got some RTC batteries on order, should deliver tonight so I’ll update probably later this evening. Their support replied to my email and said to remove the RTC battery and re install it, so I’ll try that too before a new battery and let you know if any change

That won’t do shit, don’t bother. Both my units wont respond even after RTC battery change.

Are you using a 12V 3A power supply?

Yeah no luck on the RTC removal and reinstall. Fresh batteries maybe blew away in the wind yesterday so I couldn’t try them. Customer service replied to my emails though and said they’d replace so check in with them

Yes,plese use casaos,not find zima to get ip.

No luck with new RTC batteries, but icewhale emailed me a confirmation of a replacement unit