Default system Password?

Hi, I am excited to test ZimaOS.

I have an Nvidia card I want to use for Jellyfin encoding. I need to install Nvidia drivers. ZimaOS is missing CLI from top left. Tried to SSH in so I can install but I don’t know the default system password, and I wasn’t prompted to create one on setup…?

Try this: testonly

Cheers.

No luck, but thank you for the response.

To be clear, I am fairly new to this, and the ssh command should be ssh <CasaOS username>@<LAN IP> yes?

Also this post seems to indicate that Nvidia/CUDA drivers are pre-installed: Tiger Wang: "Remote development directly on #ZimaOS, an embedd…" - Fosstodon

Can anyone confirm or deny?

try this one
ssh root@
password:testonly
next version will be support Nvidia/CUDA drivers

Hey, that worked, thank you.

But now I have a whole new problem. I assumed since it’s Debian-based that typical Debian commands would work but that doesn’t appear to be the case.

root@ZimaCube:~# sudo apt install nvidia-driver -bash: sudo: command not found root@ZimaCube:~# apt install nvidia-driver -bash: apt: command not found root@ZimaCube:~# install nvidia-driver -bash: install: command not found

But that’s great to hear that Nvidia will be preinstalled in the next version! If that will be anytime soon I am okay to patiently await it’s arrival.

Is there a way to change the SSH password?

I would really try to test ZimaOS on bare metal, but that way it is jus too insecure for me.

Try using the passwd command to change the password.

I already tried.

The passwd binary is not available.

Oh, and what is the password for SMB access?

My user credentials from the WebUI do not work.

The default account password is guest guest

1 Like

After Alt F2 I get ZimaCube login: (here I can type what I want), than for the password no characters show up. What am I doing wrong?

How to open ssh in ZimaOS? Hope this link can help you.