Pi-hole port 53 “address already in use”

I already know what’s running on port 53. Ubuntu has systemd-resolved listening on port 53 by default, which is what’s blocking pihole from starting.

I can’t fix it by using a different port, but changing /etc/resolv.conf and stop “systemd-resolved” run pi-hole successfully .

We have tested disabling ‘systemd-resolved’, it can release port 53, but we need to evaluate the negative impact of disabling this service, thanks for your feedback!!

Firstly, thank you for the quick response
I love zimaos system. It is fast, light, and has beautiful interfaces.
Is there a way to use pi-hole or adguard on it?

We have fixed this issue in version, feel free to test it.

When i add or modify one of the options, it is not saved because the Config file is read-only.
This problem exists in all Docker programs .

I’m still having this problem installing AdGuard

I’m also still having this problem with ports 53 and 67 for PiHole and AdGuard. I have been unable to disable them in a persistent way.

I was able to SSH to the ZimaOS host and

 killall dnsmasq


systemctl stop systemd-resolved

to release these ports from the host. Just haven’t figured out how to make it persistent for restart.