Proxmox installation, can't see my NVMe


I’m trying to install proxmox on my zimablade.
I bought the PCIe to NVMe & NGFF SSD Adapter ZBA004 from the Icewhale store and an Lexar NM710 M.2 1 TB PCI Express 4.0 NVMe.

When I boot into bios I can find the Lexar drive in boot options. When I run the Proxmox installer USB however, I cannot find the NVME drive in the installation options.
I tried UEFI and legacy mode in BIOS

I booted into proxmox advanced installation options and ran the following commands (see screenshot). The NVME is not detected.

When I plugin the PCI adaptor and NVMe into my windows PC and run the proxmox USB, it finds the NVMe just fine. I can install proxmox just find. When I replugin the adaptor and drive in the zimablade and boot from the drive like that, I get a boot error.

Anyone got any solution?

I ‘fixed’ it by swapping the Samsung NVMe in my windows PC with the Lexar NVMe I bought for the zima board.
The Lexar NVMe works perfectly on my windows PC but not on the Zima board. The Samsung NVMe works with both.
Seems to be a driver issue of the Zima board?

Not all NVMe chipset controllers are created equal.

Lexar NM710 is a gen 4 device and should be backwards compatible but if you google that model there are other reposts of it not being seen by Mobos and Raspberry Pi NMVe hats.

It’s probably an issue in the backwards compatibility than a driver issue, but glad it’s working in the swapped setup.