Requesting Assistance for Enabling HTTPS on Nextcloud Installed on CasaOS

Dear Icewhale Forum Members,

I hope this message finds you well. I am seeking guidance regarding the installation of Nextcloud on CasaOS. I have encountered an issue where Nextcloud displays a warning indicating that I am not using HTTPS, consequently restricting access to certain functionalities.

I have successfully installed Nextcloud on my system but require assistance in enabling HTTPS to ensure secure communication. I am unfamiliar with the necessary steps to configure HTTPS within CasaOS or specifically for Nextcloud.

Could anyone provide detailed instructions or guidance on how to set up HTTPS for Nextcloud on CasaOS? I understand the importance of secure connections and would greatly appreciate any help or advice you could offer to resolve this issue.

Thank you very much for your time and assistance.

Best regards,

1 Like

Thank you for reaching out regarding setting up HTTPS for Nextcloud on CasaOS. Here are the steps to enable secure connections:

Install an SSL certificate. You can use a free one like Let’s Encrypt or purchase a commercial certificate.
Place the certificate files (fullchain.pem and privkey.pem typically) in the Nextcloud app data directory, e.g. /var/lib/apps/nextcloud/https
Edit the Nextcloud config file at /var/lib/apps/nextcloud/config/config.php. Set ‘overwriteprotocol’ to ‘https’ and update the paths to your certificate files.
For example:

‘overwriteprotocol’ => ‘https’,

‘ssl_method’ => ‘letsencrypt’,

‘ssl_certificate’ => ‘/var/lib/apps/nextcloud/https/fullchain.pem’,

‘ssl_certificate_key’ => ‘/var/lib/apps/nextcloud/https/privkey.pem’,

Restart the Nextcloud app service for changes to take effect.
I hope these steps help you in setting up HTTPS access for Nextcloud on CasaOS. Secure connections are important for privacy and functionality. Let me know if you have any other questions!

1 Like