Stuck on "Loading on initial ramdisk ..."

I have received earlier this week the ZimaBlade NAS kit and today I wanted to try it out. I can see the redlight, but when I try to boot from th onboard mmc Debian, it is always getting stuck on “Loading initial ramdisk …”. I have tried to boot using both kernel available on GRUB and also trying their associated recovery option. No luck.
I have then tried to boot from an endeavourOS USB stick, when I launched the installer I always got a black screen, also in fallback mode.
Then I have tried installing Proxmox, and always a black screen when launching the installer using both 7.4 and 8.1 ISO images, using both text/graphical interfaces, and even forcing the “nomodeset”, and trying with 2 different screens.
Something interesting with Proxmox 7.4: trying to launch the installer in debug mode I see a “Kernel Panic - not syncing”.
Finally I have also double checked my RAM was correctly inserted, and from the bios I correctly see the 16384MB listed. Anyway, the memtest from the proxmox 7.4 installer fails.
As last resort I have tried also to reset the RTC battery, but nothing changed.

Is it possible I have received a defective RAM unit?

Edit: Memtest86+ ongoing launched from the official zimablade ISO:

Please contact IceWhale Support