ZimaBlade - no network interface?

Just got my Zimablade, installed the memory, got it all hooked up to video, network, etc and booted it up. It just boots to the console login and it does not find any network interfaces. Tried booting a few other Linux OSes from a flash drive and have the same result. Poked around in the BIOS and don’t see anything immediately obviously wrong. Reloaded defaults there but still seeing the same issue. Any idea what might be wrong? Just a defective unit?

Here is the result of looking at the network devices via the console:

It doesn’t seem to see the network card. Try “inxi -Ni” or “lshw -C network” from a terminal. If you don’t have these programs installed and can’t do downloads, import them with a USB stick, downloading them first from the debian repositories (bullseye).

Thanks – was able to get those packages installed by temporarily using a USB Ethernet adapter, then rebooted connected directly to Ethernet and ran those commands. Still doesn’t see a network card (other than the docker interface).


this is not a good result. It doesn’t seem to detect the network card. try giving the command: ip link set docker0 up Let’s see what the system responds.
I’ll post what the command responds to ip a my zimablade (ip’s are blacked out):

$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether xxxx.xxxx.xxxxx
inet xxx.xxx.xxx./24 brd xxx.xxx.xxx.255 scope global dynamic noprefixroute enp2s0
valid_lft 861906sec preferred_lft 861906sec
inet6 xxxxxxxxxxxxxxxxxxx/64 scope global dynamic noprefixroute
valid_lft 6683sec preferred_lft 3083sec
inet6 xxxxxxxxxxxxxxxxxxxxxxxxxxx64 scope link noprefixroute
valid_lft forever preferred_lft forever
3: docker0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
link/ether xxxxxxxxxxxxxxxxxxxxxxxxxxx
inet xxx.xxx.xxx/16 brd xxx.xxx.xxx.255 scope global docker0
valid_lft forever preferred_lft forever
inet6 xxxxxxxxxxxxxxxxxxx/64 scope link
valid_lft forever preferred_lft forever

Edit: If you want to post text from terminal instead of photographing it, select the text in the terminal and then use the key combination ‘Ctrl+Shift+C’ to paste it into a file ‘Ctrl+V’ to paste it into another terminal ‘Ctrl+shift+V’

Thanks. IceWhale support agrees that the unit seems to be defective, and started the process for replacement.