Zimablade not turning on

Having problems with zimablade. When I first got it, but dumb luck I managed to find a adapter and it worked, went to casaos and everything, but one I unplugged it and plugged it back in, the red light turns on then turns off immediately and I can’t get anything to display/work. So I caved and bought the official adapter on the website, got it today and it does the same thing as the adapter mentioned above. RAM is installed on day 1. is there a fix or am I screwed?


What is the specification of the power supply you first used?

Output of 15v 3a or 12v 3a

I’m having the same issue. Tried three power supplies: 12V 3A (official power supply @ 36W), 12V 3A (45W) and also 12V 3A (65W). No luck. Plugged it in once, got to CasaOS, but it won’t come back on.

FYI I was using the official power supply, but that doesn’t even power the red light; it flashes on then off in about 1/4 of a second.

Using the 45W power supply maintains a steady red light, however.

Thankfully, tech support helped me so I got it to work. You’ll have to take it apart, find the RTC battery and just take it out and but it back in and I should work, and it worked for me. Lemme know if it works!