ZimaOS fails to update

ZimaOS fails to update from 0.49 to 0.491 and 0.492 using the update tag in the settings.

Also stopped all running apps before update but receive this message after package 4 of 7.

“Installation error: Failed updating slot rootfs.0: Opening output device /dev/disk/by-partlabel/casaos-system0 failed: Device or resource busy”

Any ideas or should I re-install using new image.

The upgrade failed because the USB hard disk’s auto-mount feature automatically mounted the partition we wanted to upgrade.
The temporary solution is to disable the USB auto-mount feature in the settings and perform the upgrade again.
In the meantime we will fix this issue in the next OTA update.

1 Like

I have already tried this and also closed all apps so that there was no other access by apps.
Switched off news feeds too. The update still fails with same message. Is ther a way to turn off using CLI ?

You can login vis ssh and run lsblk if you found dev/sda3 of /dev/sda5 has mountpoint, then use umount /dev/sda3 or umount /dev/sda5. after that run lsblk, Make sure they are no longer mounted.
Finally you can run update.

Sounds good

What is the username and pw for ssh?.These were not set by me during installation, I assume these are at default

Try root/testonly


That worked perfectly.
Many thanks