App Store Apps Can't Access My Storage

I got my Zimacube and setup was relatively easy. I installed an M2 and HDD which both show up as available storage when I look in Files. My problem comes when I try to install a program like Jellyfin. I downloaded and installed it off the app store and it runs. However, when setting up where I want the media to pull from, it does not show any of my drives. It only shows directories from the ZimaOS HD. Nothing from the drives I added. I tried with another app, Emby, and it was the same result.

I imagine it must be some sort of permissions issue for the app to see my storage but I have no idea how to enable it.

1 Like

got my device 3 days ago, now I’m about 20 hours into trying to get Zima Cube to operate using external added storage, you are NOT alone!!

I an no closer to being able to use external storage for apps than I was before. I’m very disappointed in the functionality of this.

The best way I can tell, is that we need to install a larger NVME on the main board and run with that until ZimaOS devs make a functionality to remount the drive paths we need onto new drives. I’m pretty sad about how badly this all works right now. It’s like the software side was an afterthought, but to me, it’s WHY I bought this in the first place.

I’m going to install ZimaOS on a new drive and hopefully that works… but I somehow doubt it.

I wish the Devs woudl answer this question, and mine, asking the same thing.

1 Like

@tvari @bkellogg
In the App’s settings, adjust the volume location to your newly added hard drive
In Jellyfin and Emby and all apps, they can only access the volumes you define.
I’m glad you raised this question. ZimaOS will try to help users do this setting in future versions.
image
image
image

Thank you very much for your trust in ZimaOS. Maybe ZimaOS is not good enough now. I will leave a message here later on how to make the new version “closer to being able to use external storage for apps”. Sincerely look forward to your opinions. @bkellogg

thanks for the response, that might help, for now I’ve got my backuos running on the main OS, and can at least use the hdd as a good network drive. this will be sufficient until I can use the tips you have suggested.

I think the issie was with hard drives added individually, not put into RAID, those drives were not useful as a destination for app settings host/directory changes.

Thank you! It now works like a charm.

image
The hard drives added individually can be set up as shown in the screenshot. Once you insert these hard drives into ZimaCube, you can use them by enabling them in the settings.