Welcome to the ZimaOS Open Beta Program!

Welcome to the ZimaOS Open Beta Program!

Dear CasaOS Community,

Dear CasaOS Community, we are thrilled to introduce an exciting development in our journey to provide innovative software solutions - ZimaOS, the PRO version OS product! We sincerely invite you to be a part of this significant milestone by joining our ZimaOS Beta Open Program.

What is ZimaOS?

While CasaOS continues to thrive as a community-driven platform, ZimaOS is designed to cater specifically to the needs of professional application scenarios. It combines the robustness of CasaOS with new features and capabilities tailored to the demands of some professional filed. ZimaOS is poised to empower PRO scenarios with enhanced tools for more networking, ease of use, lightweight AI and more. We will plan to release ZimaOS through the Zima family of hardware to meet people’s needs for more professional scenarios to fully build the next generation of personal cloud solutions.

ZimaOS vs CasaOS Features Plan

ZimaOS Open for Testing! We Need Your Feedback !

To ensure that ZimaOS meets the highest standards of performance, security, and user-friendliness, we are opening ZimaOS for testing! As a very first user, you’ll have the unique opportunity to be among the first to experience ZimaOS before its official release. Your valuable suggestions and feedback will directly shape our final product.

:arrow_right: Step 1: Download ZimaOS available version and carefully read the 【Testing Guide】
:fire:【AI Chat Introduced】ZimaOS V1.0.1
-【RAID Available】ZimaOS V1.0.0
-【Update】ZimaOS V0.4.9.4
-【Update】ZimaOS V0.4.9.3
-【Update】ZimaOS V0.4.9.2
-【Update】ZimaOS V0.4.9.1
-【Original】ZimaOS V0.4.9

:arrow_right: Step 2: Enjoy your new journey!

:arrow_right: Step 3: Any issues or comments are welcome. Feel free to post ZimaOS topic on IceWhale forum. Remeber to choose tag’ zimaos open testing’.

Post Issue on forum (sample):

Describe the bug
A clear and concise description of what the bug is.

Screenshots
If applicable, add screenshots to help explain your problem.

Other feedbacks

:warning: ZimaOS is currently in an unstable version. Please download and use it with caution.

Join ZimaOS Open Test Partner Team!

If you have further interest of ZimaOS, we have Partner Plan that is recruiting 50 test specialists to explore the depthsof ZimaOS’s beta features.

Yes we are recruiting 50 test specialists from our community! As a test specialist, you’ll be among the first to experience beta functionality before general release. You’ll also have more granular control and expanded permissions to thoroughly test all aspects of ZimaO S.

Please take a moment to fill out this form to express your interest. We will follow up with next steps via Discord or email after receiving your completed form. Let’s get hands-on with ZimaOS early and directly influence the product through your findings. Your real-world testing and usage will help ensure ZimaOS delivers an outstanding experience in its final release.

CasaOS Continues to Thrive

We want to reassure our CasaOS community that this new venture will not diminish our commitment to CasaOS itself. CasaOS remains a cornerstone of our mission, and we will continue to invest in its development. CasaOS is, and always will be, a community-driven software, and your contributions and support are what make it exceptional.

Join us on this exciting journey as we prepare to launch ZimaOS. Your participation in the testing project is not just an opportunity to try out new software, but a chance to help us build a product that will empower shape NEXT personal cloud solution.

Thank you for your continued support, and we look forward to having you on board!

Sincerely,

CasaOS Team

2 Likes

What an incredible announcement!!!
I have been having a poke arround on this and it’s very clear that IceWhale have been listening to the community feedback!

In my experience everything from IW has always been pretty polished and clean and this is no exception, even at this early stage :slight_smile:

The new Files app is amazing IMO and offers a lot more visability over the drives / files

I have also tested out the backup function using the Zima App from my laptop and it’s working great :slight_smile:

One thing i REALLY like is the built in remote connectivity using Zero Tier One…

I have tested this from my mobile phone using the ZTO app and it works amazingly. no speed reduction that i have noticed and gives simple access with little to no setup / configuration :slight_smile:

One thing i have noticed that was odd was the findzima also found a lot of other ‘random’ devices so i had to make sure i selected the correct one. (*Edit this has been resolved)

The current image also seems to be missing the Terminal BUT that can come later in the testing :slight_smile:

2 Likes

Regarding the findzima questions has been fixed.

1 Like

Updated my post and as always IW team SUPER quick off the mark to get this resolved :slight_smile:

What is default login/password for ssh and smb protocols?

Default ssh login/password is root/testonly default port is 22, smb protocol is min protocol = SMB2

Hi, everything works reasonably well, but I don’t see any IP on remote connection. I installed Zerotier one app on my phone and added the network ID but it doesn’t connect. Is it a router issue? Perhaps I should open port 9993?

@Fido Hi, can you please provide me with what you did before you discovered this problem? We also found this problem on our side.
The cause of the problem is: zerotier-one automatically assigns a mismatch between the network segment and the gateway, which makes it impossible to separate the available ip for zimacube, which makes it impossible to access it through zerotier.
The command to determine if the network segment and gateway match is as follows: cat /var/lib/zerotier-one/controller.d/network/*.json

The temporary solution is as follows:

network_id=$(zerotier-cli listnetworks)
zerotier-cli leave $network_id
systemctl stop zerotier-one
cd /var/lib/zerotier-one/
rm -rf . /controller.d/
systemctl start zerotier-one
reboot

Thanks for your feedback, I hope this temporary solution works for you!

I just turned off the remote connection from the switch. Then I turned it back on and the IP address was no longer displayed. I solved it by reinstalling the OS.

1 Like

A new big problem. Cutting and pasting archives have deleted all the archives.

Can u provide a video for us to reproduce the problem, I tried copying and cutting a single zip file and it doesn’t cause my other zip files to be deleted, thanks for your feedback

I have one copy of ZimaOS running on a Dell Optiplex 3050 and it is working great with no problems. My other version is on the ESXI 7.0 Server. It’s set up with 6 Core 16 GB RAM. The boot drive is 500 GB and is set as a passthrough. I created 5 500 GB virtual drives. I can’t find anything not working but I have a warning on the dashboard.
Storage

As you can see, I have also added 5 hdd’s to the pve and it shows no problems. The Damage you are seeing is provided by the Storage Manager data.
Can you provide us with your Storage Manager interface so that we can further troubleshoot if the problem is due to data inconsistency? Thanks for the feedback.

Will get that info for you later this evening when I am home.

@djtech Could you explain how you got it to work on ESXi? I can get it to boot, but it hangs at the init waiting for root device. (I have ESXi 6.5U2…)

Here’s the vmx file:

.encoding = "UTF-8"
config.version = "8"
virtualHW.version = "13"
vmci0.present = "TRUE"
floppy0.present = "FALSE"
numvcpus = "4"
memSize = "8192"
scsi0.virtualDev = "lsisas1068"
scsi0.present = "TRUE"
ethernet0.virtualDev = "e1000"
ethernet0.networkName = "vlan2"
ethernet0.present = "TRUE"
displayName = "srv-zima-01"
guestOS = "other3xlinux-64"
uuid.bios = "56 4d 1d 5a 15 63 f5 7d-4b 1f 5a 5e 23 81 88 9f"
uuid.location = "56 4d 1d 5a 15 63 f5 7d-4b 1f 5a 5e 23 81 88 9f"
vc.uuid = "52 85 59 40 29 30 9b 06-c7 9f 63 6a c3 88 4a 32"
ethernet0.addressType = "generated"
ethernet0.generatedAddress = "00:0c:29:81:88:9f"
vmci0.id = "595691679"
cleanShutdown = "TRUE"
sched.cpu.units = "mhz"
sched.cpu.affinity = "all"
tools.upgrade.policy = "manual"
toolScripts.afterPowerOn = "TRUE"
toolScripts.afterResume = "TRUE"
toolScripts.beforeSuspend = "TRUE"
toolScripts.beforePowerOff = "TRUE"
tools.syncTime = "FALSE"
sched.cpu.min = "0"
sched.cpu.shares = "normal"
sched.mem.min = "0"
sched.mem.minSize = "0"
sched.mem.shares = "normal"
ide0:0.deviceType = "atapi-cdrom"
ide0:0.present = "TRUE"
scsi0:0.deviceType = "scsi-hardDisk"
scsi0:0.fileName = "srv-zima-01.vmdk"
scsi0:0.present = "TRUE"
sched.scsi0:0.throughputCap = "off"
sched.scsi0:0.shares = "normal"
usb.present = "TRUE"
ehci.present = "TRUE"
ide0:0.fileName = "/vmfs/volumes/64970260-265194d9-8193-00265540be12/Software/gParted/gparted-live-1.4.0-1-amd64.iso"
ide0:0.startConnected = "FALSE"
ide0:0.allowGuestConnectionControl = "FALSE"
ide0:0.autodetect = "TRUE"
sched.cpu.latencySensitivity = "normal"
svga.autodetect = "TRUE"
tools.guest.desktop.autolock = "FALSE"
nvram = "srv-zima-01.nvram"
pciBridge0.present = "TRUE"
svga.present = "TRUE"
pciBridge4.present = "TRUE"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.functions = "8"
pciBridge5.present = "TRUE"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge6.present = "TRUE"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge7.present = "TRUE"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
hpet0.present = "TRUE"
firmware = "efi"
uefi.secureBoot.enabled = "FALSE"
numa.autosize.vcpu.maxPerVirtualNode = "4"
numa.autosize.cookie = "40001"
sched.swap.derivedName = "/vmfs/volumes/64f1c88c-80b0ca1a-4d1b-00265540be12/srv-zima-01/srv-zima-01-880f4ca8.vswp"
pciBridge0.pciSlotNumber = "17"
pciBridge4.pciSlotNumber = "21"
pciBridge5.pciSlotNumber = "22"
pciBridge6.pciSlotNumber = "23"
pciBridge7.pciSlotNumber = "24"
scsi0.pciSlotNumber = "160"
ethernet0.pciSlotNumber = "32"
vmci0.pciSlotNumber = "33"
scsi0.sasWWID = "50 05 05 6a 15 63 f5 70"
ethernet0.generatedAddressOffset = "0"
monitor.phys_bits_used = "43"
vmotion.checkpointFBSize = "4194304"
vmotion.checkpointSVGAPrimarySize = "16777216"
softPowerOff = "FALSE"
usb.pciSlotNumber = "34"
ehci.pciSlotNumber = "35"
usb:1.speed = "2"
usb:1.present = "TRUE"
usb:1.deviceType = "hub"
usb:1.port = "1"
usb:1.parent = "-1"
svga.guestBackedPrimaryAware = "TRUE"
usb:0.present = "TRUE"
usb:0.deviceType = "hid"
usb:0.port = "0"
usb:0.parent = "-1"
migrate.hostLog = "./srv-zima-01-880f4ca8.hlog"

TIA